User Tools

Site Tools


Sidebar

selfpublishing:exporting-scrivener-to-indesign

Scrivener から InDesign へ書き出し

(1)Scrivener:文章作成

  • lock paragraph
  • セクションタイトルは★で始める

(2)Scrivener:compile

  • Wordで書き出し
  • URLのリンクは外す
  • 余計なヘッダー・フッターは除く

(3)Word:整形

  • 置換:^p^m→^mでページ区切り前の余計な改行を削除
  • URLのリンクを消し忘れていたらここで消す(すべてを選択して command+Shift+F9)
  • 画像が含まれる場合、削除しておく(InDesign の配置で正しく読み込めないため)。別途 InDesign で画像を配置する。

(4)InDesign:ドキュメントを新規作成

  • US Tradeでドキュメントを新規作成する場合
    • 152.4×228.6mm

  • 新書サイズで新規作成する場合
    • 107.95×174.498mm
    • のどは広めにする(Luluの紙は固めなので)。

(5)InDesign:配置でWordを読み込む

  • 脚注がある場合、あらかじめ脚注用の段落スタイルを作って、「書式>脚注オプション」で設定しておく。
  • 配置の際にレイアウトグリッドとフレームグリッドがずれてしまうとき
    1. 最初のページに手動でフレームグリッドを置く。それをレイアウトグリッドに合わせる。
    2. そこに配置する(一旦1ページ分のみ)
    3. 2ページ目を作成。
    4. 1ページ目の右下の赤くなったボタンをクリックし、2ページ目にShiftキーを押しながら配置する(以降一気に配置され、さらにレイアウトグリッドにそろっている)。※2ページ目だけまたずれることがあるので、その時は手動で修正。
  • Wordの中央寄せが反映されないので、手動設定

(6)InDesign:置換で空行を削除(段落の初めを字下げをする場合)

  • 「^\s*$\r」を検索文字にする

(7)InDesign:字下げ(段落の初めを字下げをする場合)

  • (テキストフィールドが選択されていない状態で)書式>文字組みアキ量設定>基本設定 で段落字下げを新規作成しておく。
  • 段落字下げを1文字とし、段落先頭始め括弧類は「段落字下げ+始め括弧半角」がオススメ。

(8)InDesign:段落スタイル

  • 通常本文用の段落スタイルを作り、全テキストに適用。
  • 「日本語文字組版」で「文字組み」を作成した段落字下げの文字組みアキ量設定にする。
  • セクションタイトル用の段落スタイルを作っておく
    1. 「インデントとスペース」で「段落前のアキ」「段落後のアキ」を設定しておく。レイアウトグリッド設定の「段間」の数値を参考に。「段落前のアキ」は2行空行がいい。
    2. 「日本語文字組版」で「文字組み」を「なし」に

(9)InDesign:段落スタイルの適用

  • 置換>正規表現で「^★.*$」を検索文字にし、置換形式をセクションタイトル用の段落スタイルにする。
  • ★を置換:削除

(10)InDesign:ノンブル、もくじ、ヘッダー

  • セクション名をヘッダーに表示させる場合、章タイトルページで正しく表示されているかチェック。

(11)InDesign:IPAフォントだとアポストロフィ後にアキができてしまう

  1. 文字スタイルで「詳細文字形式>文字後のアキ量」を「アキなし」に設定。
  2. アポストロフィをこの文字スタイルで一括置換。

(12)InDesign:索引用単語の抽出

  1. Wordに出力して文書を開く。
  2. 「高度な検索と置換」で「ワイルドカードを使用する」「検索結果をすべてハイライト表示する>メイン文書」にチェックを入れる。
  3. 例えば『』で囲まれた単語を検索後にするなら→『*』で検索。すべてがハイライトされるのでコピー。
  4. テキストエディターなどへペースト
  5. エクセルへペースト、並び替え
selfpublishing/exporting-scrivener-to-indesign.txt · Last modified: 2019/08/14 02:39 by wacw